messed up demo recording - Forum

Internet DOOM Utilities
Main | messed up demo recording - Forum | Registration | Login
[ New messages · Members · Forum rules · Search · RSS ]
Page 1 of 212»
Forum » IDE discussion and other.. » Bugs, remarks » messed up demo recording
messed up demo recording
ModeneseAdrianoDate: Thursday, 2012-08-30, 13:50 | Message # 1
Private
Group: Users
Messages: 10
Reputation: 0
Status: Offline
ok so, this is what happened:
I used to have IDE folder inside ST's one, then after installing Zandronum I decided to make it "independant" by copying IDE folder outside of ST, and changing ST path to zandronum.exe in "Programs" section... now demos keep being recorded with same name(overwriting the previous demo, unless I rename it before I join another server) instead of the usual DATE_TIME_WAD format, no matter what port i use(Skulltag.cld for ST, zdaemon.108.zdo for zd). Used to be alright before I did what I just described, using a fresh ini and deleting/re-extracting IDE didn't help either.
Any clue about how to solve this?

EDIT: if i set demo path to old demo folder demo name is registered correctly once again, so looks like it's a path-related problem.. now the real question is how to set whatever demo path without encountering such problems :\


Message edited by ModeneseAdriano - Thursday, 2012-08-30, 14:30
 
bondDate: Friday, 2012-08-31, 02:39 | Message # 2
Admin
Group: Administrators
Messages: 148
Reputation: 0
Status: Offline
Its strange..
Especially "using a fresh ini and deleting/re-extracting IDE didn't help either". That is if you delete ide.ini and start ide with new config, setup all required paths - it doesnt work well?
DATE_TIME_WAD should work in all cases except if you setup demo record manually in Additional Doom Parameters, like "-netrecord mydemo"
What path for demos do you use? Can it be prohibited for writing (for example "Program files" folder in Windows 7 OS)?
What happen if you ectract ide zip to new folder (not Program Files) and setup program and wads paths only (left demos path default - that is in IDE dir)
Can you send me your ide.ini (that doesnt work well) - just remove any personal info from it (passwords, buddies etc)?

btw, you said "now demos keep being recorded with same name" - what was this name?
 
ModeneseAdrianoDate: Friday, 2012-08-31, 11:32 | Message # 3
Private
Group: Users
Messages: 10
Reputation: 0
Status: Offline
I don't think it's a ini problem, just about the path...
if I put demo directory to I:\Program Files (x86)\skulltag2\IDE\demos (the path I've always had before) there is no problem, demos are recorded with the correct DATE_TIME_WAD format in the proper port folder(Skulltag Demos, Zdaemon Demos etc)
but if I change path to any other directory(even outside of Program Files) it creates a port folder and a demo with bad name outside of the port folder(e.g. let's say i put I:\IDE\demos as path, if I explore that folder after I leave a server there is:
-a new Skulltag Demos folder and a Skulltag.cld demo file if I played in a skulltag/zandronum server
-a new ZDaemon Demos folder and a ZDaemon.108.zdo demo file if I played in a ZDaemon server

I checked writing permissions in the folder where demos are recorded properly to see if it has different flags from the other ones, but seemed the same...
Does IDE create any registry key/cache config file/etc that remains even if I delete IDE folder?

EDIT: I did cut/paste the old IDE folder from inside ST folder to I:\Program Files (x86), now demos are recorded properly into I:\Program Files (x86)\IDE\demos, and this same path wasn't working when I still had old IDE folder inside ST(WITHOUT Ide.exe and Ide.ini in it).. seems like demos are recorded properly JUST in that specific folder no matter what the path is, since there still is the same problem in all the other directories. Oh man this is so weird, here's ini(just in case, even if it doesn't seem an ini-related problem to me) http://www.speedyshare.com/Zhmn8/Ide.ini


Message edited by ModeneseAdriano - Friday, 2012-08-31, 12:33
 
bondDate: Saturday, 2012-09-01, 10:54 | Message # 4
Admin
Group: Administrators
Messages: 148
Reputation: 0
Status: Offline
I tried to reproduce this problem using various progam locations including those from your .ini, but without success: all worked fine for me
Can you try my debug program which shows command line parameters IDE transmit to port client: http://doomutils.ucoz.ru/files/client.zip ?
Unzip client.exe, put it into skulltag/zandronum folder and rename to skulltag.exe or zandronum.exe (or just point IDE to it)
When start game it shows cmd parameters in console windows - copy it contents and send me (select/copy options are in windows menu)
Do it for good and bad situations if possible
 
ModeneseAdrianoDate: Saturday, 2012-09-01, 19:33 | Message # 5
Private
Group: Users
Messages: 10
Reputation: 0
Status: Offline
http://www.speedyshare.com/EqBjA/client-outputs.zip
there's a log where I used the working demo path, and another one where name is recorded badly(as Skulltag.cld)
the path used for the bad one is I:\Program Files (x86), I can make more if necessary
 
bondDate: Sunday, 2012-09-02, 04:20 | Message # 6
Admin
Group: Administrators
Messages: 148
Reputation: 0
Status: Offline
Weird..
what OS do you use? windows 7 x64? Do you use some optimization programs on it?
Anyway, try this: http://doomutils.ucoz.ru/files/ide518-1.zip , i made some workaround of this problem
 
ModeneseAdrianoDate: Sunday, 2012-09-02, 08:32 | Message # 7
Private
Group: Users
Messages: 10
Reputation: 0
Status: Offline
this version works with other paths too, thanks for all the support. Anyway yeah, I have win7 64bit with some Gigabyte motherboard optimization software.. just out of curiosity, what exactly was causing the problem and how did you manage to fix it?
 
bondDate: Sunday, 2012-09-02, 09:46 | Message # 8
Admin
Group: Administrators
Messages: 148
Reputation: 0
Status: Offline
I dont know exactly the reason of this
To simplify processing of pathnames with spaces i convert them to short path names (like in DOS, 8.3 format)
It seems on some systems it doesnt work well, dont know why
For example in you case, in "bad" example, part of name converted to short format:
I:\Program Files (x86) -> I:\PROGRA~1
and part - no:
Skulltag Demos -> Skulltag Demos
When IDE transmit this to client as parameter, space in name becomes separator between parameters, so filename for demo is
I:\PROGRA~1\Skulltag
and other part (with wads and date) is omited
So i put quotes around this parameter to make it work
"I:\PROGRA~1\Skulltag Demos\2012.09.02_02.21.53_skulltag_actorspk3.skulltag_data_126pk3.duel32-beta3pk3.duel32_shootfixpk3.cld"

If you want, we can try to go deeper into the problem
try this: http://doomutils.ucoz.ru/files/ide518-2.zip
it will print debug info in Log when launch game
copy it here, we will see
 
ModeneseAdrianoDate: Sunday, 2012-09-02, 13:38 | Message # 9
Private
Group: Users
Messages: 10
Reputation: 0
Status: Offline
ok, this is the path that always worked:
Code
20:17:17: Internet Doom Explorer started. Happy Fragging ;-)
20:17:17: Skulltag LANSocket: OK
20:17:17: Number of Skulltag servers=381
20:17:17: IDE is up to date
20:17:18: IP2C is up to date
20:17:42: debug1=I:\Program Files (x86)\IDE\demos=
20:17:42: debug2=I:\Program Files (x86)\IDE\demos\Skulltag Demos\=
20:17:42: debug3=I:\Program Files (x86)\IDE\demos\Skulltag Demos\=
20:17:42: debug4=I:\PROGRA~1\IDE\demos\SKULLT~1\=
20:17:42: debug5==
20:17:42: debug6= -record "I:\PROGRA~1\IDE\demos\SKULLT~1\%DATE%_%TIME%_%WAD%.cld"=
20:17:43: Launch game, server Skulltag  83.170.101.240:17041


and this is one of the paths where the problem occurred:
Code
20:21:59: debug1=I:\Program Files (x86)=
20:21:59: debug2=I:\Program Files (x86)\Skulltag Demos\=
20:21:59: debug3=I:\Program Files (x86)\Skulltag Demos\=
20:21:59: debug4=I:\PROGRA~1\Skulltag Demos\=
20:21:59: debug5==
20:21:59: debug6= -record "I:\PROGRA~1\Skulltag Demos\%DATE%_%TIME%_%WAD%.cld"=
20:21:59: Launch game, server Skulltag  83.170.101.240:17041


in the 2nd log "Skulltag Demos" doesn't get shortened.. well at least now demos are named properly, regardless of what path I use.
Let me know if you want to make further tests or this is fixed enough for you, thanks again
 
bondDate: Sunday, 2012-09-02, 14:17 | Message # 10
Admin
Group: Administrators
Messages: 148
Reputation: 0
Status: Offline
well, may be it is something in your system, that prevent winapi functions to work properly sometimes.
or this functions are outdated in modern OS, and should be replaced with new.. dont know
seems i need to investigate code for similar problems

btw, can you try this command in console window (run cmd.exe):
fsutil behavior query disable8dot3 I:
it will show current 8.3 conversion status on disk I:
 
ModeneseAdrianoDate: Sunday, 2012-09-02, 16:06 | Message # 11
Private
Group: Users
Messages: 10
Reputation: 0
Status: Offline
roughly translated with google, since it was in italian:
Code
The volume status for Disable8dot3 is 0 (8.3 file name creation is enabled).
The state of registry to NtfsDisable8dot3NameCreation is 1 (creation
    of 8.3 file names disabled for all volumes).
Based on the above two settings, in I: the creation of 8.3 file names
    is disabled.


Message edited by ModeneseAdriano - Sunday, 2012-09-02, 16:06
 
bondDate: Monday, 2012-09-03, 01:15 | Message # 12
Admin
Group: Administrators
Messages: 148
Reputation: 0
Status: Offline
seems there is source of problems - "in I: the creation of 8.3 file names is disabled."
by default it is enabled. if you disable it, it can speed up some programs (indexing for example), so i asked did you use any optimization programs
strange thing for me is that part of pathnames can be shortened nevertheless
 
ModeneseAdrianoDate: Friday, 2012-09-14, 11:51 | Message # 13
Private
Group: Users
Messages: 10
Reputation: 0
Status: Offline
sorry for bothering you again about this, but now with ide 5.25 i have the same problem when i try to PLAY demos(recording now is all fine)
so if demo path is I:\Program Files (x86)\IDE\demos\Zandronum Demos
when i try to play a specific demo the last message displayed in zandronum console is
"couldn't read file I:\Progra~1\IDE\demos\Zandronum.lmp"
if I copy demo in a folder without spaces in its name (like I:\Program Files (x86)\IDE\demos) then it gets played properly.
I even enabled 8.3 namefiles and rebooted, the problem still persists :\
Any suggestions?
 
bondDate: Friday, 2012-09-14, 15:06 | Message # 14
Admin
Group: Administrators
Messages: 148
Reputation: 0
Status: Offline
your system has very weird configuration, really )
i use short pathnames in IDE everywhere, and i wonder how IDE work on your system at all - how it finds wads, programs etc. why only demos have problems?
here is modified ide, using quotes in demonames: http://doomutils.ucoz.ru/files/ide525a.zip , try it

how did you enabled 8.3 names, what procedures?
 
ModeneseAdrianoDate: Friday, 2012-09-14, 16:13 | Message # 15
Private
Group: Users
Messages: 10
Reputation: 0
Status: Offline
regedit > NtfsDisable8dot3NameCreation > changed value to 0
then i rebooted, used the fsutil command and said 8.3 was enabled, despite still having same error with demo playing
Thanks for new exe anyway


Message edited by ModeneseAdriano - Friday, 2012-09-14, 16:13
 
Forum » IDE discussion and other.. » Bugs, remarks » messed up demo recording
Page 1 of 212»
Search:

bond © 2001-2016 Powered by uCoz