[5.08] Error message: doom2.wad needs updating... - Forum

Internet DOOM Utilities
Main | [5.08] Error message: doom2.wad needs updating... - Forum | Registration | Login
[ New messages · Members · Forum rules · Search · RSS ]
Page 1 of 11
Forum » IDE discussion and other.. » Bugs, remarks » [5.08] Error message: doom2.wad needs updating...
[5.08] Error message: doom2.wad needs updating...
caffeinegumDate: Friday, 2011-12-30, 19:49 | Message # 1
Private
Group: Users
Messages: 1
Reputation: 0
Status: Offline
[SOLVED!] Solution was simply needing to upgrade the doom2.wad manually. I ended up using: Java IWAD Patcher (1.0.2) http://user.cs.tu-berlin.de/~phenex/JIWadPatcher/ but I know there are a few applications that do the same thing. Turned out I was using the 1.666 WAD and upgraded to 1.9.

Still, very strange that ZDaemon Launcher allowed me to connect but IDE refused?

[ORIGINAL PROBLEM]

Hi, having some issues here with launching ZDaemon multiplayer games from IDE.

All WAD paths are set correctly, and I don't get the same error when connecting to the same servers with ZDaemon Game Launcher client.

When I join the server I get error message:
'C:\Doom\Wads\doom2.wad needs updating in order to play on this server. Do you want to fix the file now? YES NO' I click YES. I get a flash of a CMD window and then...nothing.

My doom2.wad comes from an original Doom 2 CD. Like I said, I've had no problems with ZDaemon server launcher and I've used the same doom2.wad with IDE and had no issues. This literally happened for the first time today.

I tried a few things,
*Copying a fresh doom2.wad from the CD, no luck.
*Turned off 'WAD Check' in options, game launches but gives me this error message in the console: 'Your DOOM2.WAD version is incorrect. Let the ZDaemon launcher try patching it for you.'
*Re-downloaded fresh IDE, still no luck

Like I said, works fine with ZDaemon launcher. Anyone have any input/experienced a similar issue? Not sure what to try next!


Message edited by caffeinegum - Friday, 2011-12-30, 20:31
 
bondDate: Saturday, 2011-12-31, 04:36 | Message # 2
Admin
Group: Administrators
Messages: 110
Reputation: 0
Status: Offline
you have several copies of doom2.wad, by the feel of it
in IDE, go to Options->Wads and click WadList button - it shows you all wads IDE can use, with pathes. if there are several copies of the same wad (doom2.wad in you case), ide will use first of them. if so, remove all redundant folders from wad search path list or rearange them (or move unnecessary wads to another folder)
 
Forum » IDE discussion and other.. » Bugs, remarks » [5.08] Error message: doom2.wad needs updating...
Page 1 of 11
Search:

Eugene Bondarchenko (aka bond) © 2001-2014 Powered by uCoz